2010年12月6日月曜日

ATmega1284P大きくていいんだけどーーエラーがーー

ATmega1284Pを一個持ってるのを思い出して、Sanguinoにしようとしてるのだが・・なんか色々エラーが出る。

Arduino IDE付属の、Avrdude.confには、記載さえ無かった。(そんなに新しいのこれ?)
Sanguino mega644pは、動かした実績が有るから、安心しきっていた。Sanguinoのリンクから拾ってきた、ATmagaBOOT168_1284P.hexってのを入れたら、入ったが、どう読んでも、64Kのとこにブートローダーが有る、Optibootにmaga1284pと設定してMakeすると出来るのだけど、これを、入れて、読み出すと全部FFになってた・何も入っていない。
同じ方式で、optibootを、644pで作ると、ちゃんと入るのだ・・何処かで何かが間違ってるらしい。

なんか最近、avrdude.confを書き足したり直したりばかりしてるな・・そんなに新しいチップばっかりなのだろうか??
ちなみに、共立のライターに至っては、メニューにさえ、mega1284pもmaga8u2/32u2など無かった。(泣)

その昔、PICの時代、秋月のPICライターで初めて、最新の安いチップが使えなくて、PICKIT2を買った直後に、何でもOKになったのを思い出す。・・最新のチップへの対応が、秋月のより、1年は速かったし・・

結局昔作ったのから、買ったのまで総動員してやってるが、これはライターの問題では無い気がしてる。

DUMPすると書けてる気がするのだが・・



01FD00  85 E0 80 93 81 00 82 E0 - 80 93 C0 00 88 E1 80 93  |................|
01FD10  C1 00 86 E0 80 93 C2 00 - 80 E1 80 93 C4 00 84 B7  |................|
01FD20  14 BE 81 FF DC D0 8D E0 - D4 D0 57 9A 96 E0 20 E3  |..........W.....|
01FD30  3C EF 41 E0 30 93 85 00 - 20 93 84 00 46 BB B0 9B  |<.A.0.......F...|
01FD40  FE CF 8B B1 80 58 8B B9 - A8 95 91 50 99 F7 FF 24  |.....X.....P...$|
01FD50  F3 94 F1 E1 EF 2E B0 D0 - 81 34 21 F4 81 E0 CA D0  |.........4!.....|
01FD60  83 E0 24 C0 82 34 11 F4 - 84 E1 03 C0 85 34 19 F4  |..$..4.......4..|
01FD70  85 E0 C0 D0 96 C0 85 35 - A1 F4 9E D0 08 2F 10 E0  |.......5...../..|
01FD80  10 93 01 02 00 93 00 02 - 97 D0 90 E0 98 2F 88 27  |............./.'|
01FD90  80 2B 91 2B 88 0F 99 1F - 90 93 01 02 80 93 00 02  |.+.+............|
01FDA0  7F C0 86 35 29 F4 84 E0 - A5 D0 80 E0 7D D0 79 C0  |...5).......}.y.|
01FDB0  84 36 09 F0 4F C0 88 D0 - 80 91 00 02 90 91 01 02  |.6..O...........|
01FDC0  A0 E0 B0 E0 23 E0 FC 01 - A0 93 5B 00 20 93 57 00  |....#.....[...W.|
01FDD0  E8 95 C0 E0 D1 E0 70 D0 - 89 93 80 91 02 02 81 50  |......p........P|
01FDE0  80 93 02 02 88 23 B9 F7 - 7F D0 07 B6 00 FC FD CF  |.....#..........|
01FDF0  40 91 00 02 50 91 01 02 - C0 E0 D1 E0 88 81 90 E0  |@...P...........|

01FE00  29 81 30 E0 32 2F 22 27 - 28 2B 39 2B 22 96 CA 01  |).0.2/"'(+9+"...|
01FE10  A0 E0 B0 E0 09 01 FC 01 - A0 93 5B 00 F0 92 57 00  |..........[...W.|
01FE20  E8 95 11 24 4E 5F 5F 4F - 82 E0 C0 30 D8 07 31 F7  |...$N__O...0..1.|
01FE30  88 81 99 81 A0 E0 B0 E0 - 25 E0 FC 01 A0 93 5B 00  |........%.....[.|
01FE40  20 93 57 00 E8 95 07 B6 - 00 FC FD CF E0 92 57 00  |..W...........W.|
01FE50  E8 95 27 C0 84 37 B9 F4 - 37 D0 46 D0 E0 91 00 02  |..'..7..7.F.....|
01FE60  F0 91 01 02 31 96 F0 93 - 01 02 E0 93 00 02 31 97  |....1.........1.|
01FE70  E4 91 8E 2F 19 D0 80 91 - 02 02 81 50 80 93 02 02  |.../.......P....|
01FE80  88 23 61 F7 0E C0 85 37 - 39 F4 2E D0 8E E1 0C D0  |.#a....79.......|
01FE90  87 E9 0A D0 85 E0 8A CF - 81 35 11 F4 88 E0 19 D0  |.........5......|
01FEA0  23 D0 80 E1 01 D0 57 CF - 98 2F 80 91 C0 00 85 FF  |#.....W../......|
01FEB0  FC CF 90 93 C6 00 08 95 - A8 95 80 91 C0 00 87 FF  |................|
01FEC0  FC CF 80 91 C6 00 08 95 - F7 DF F6 DF 80 93 02 02  |................|
01FED0  F3 CF E0 E6 F0 E0 98 E1 - 90 83 80 83 08 95 80 E0  |................|
01FEE0  F8 DF EE 27 FF 27 09 94 - E7 DF 80 32 09 F0 F7 DF  |...'.'.....2....|
01FEF0  84 E1 DA CF 1F 93 18 2F - DF DF 11 50 E9 F7 F4 DF  |......./...P....|

01FF00  1F 91 08 95 FF FF FF FF - FF FF FF FF FF FF FF FF  |................|
Total read/write size = 131072 B /66.46 s (1.93 kB/s)



ずいぶん前に作った、HIDispxまで探し出して確認してみた。

Arduino IDEから644pは書けたのだが、1284p用に修正して書いてみると


avrdude: verification error, first mismatch at byte 0xfd00
         0xff != 0x85
avrdude: verification error; content mismatch

こう出る・・・・うーん・・・


1 件のコメント:

  1. これはどうやら、avrdude.confにATmega1284Pが無い事に起因してるみたいです。MCUがいけない訳じゃ無く、Arduino付属のAvrdudeもCrossPack付属のでも駄目でした。書き足したら、普通に動きました。
    そのうち、avrdude.confをダウンロード出来るようにしときます。

    返信削除